eccotemp L5 has no hot water

Author
Freezers-full-in-Alaska
Cheeseburger
  • Total Posts : 132
  • Joined: 2010/10/14 20:30:00
  • Location: sunshine, AK
  • Status: offline
2011/09/30 21:40:49 (permalink)

eccotemp L5 has no hot water

Subject title says it all,No hot water from my L5 eccotemp . Of course it is Friday and trouble shooting line is closed. Anybody have any ideas? I have a 45psi sur-flo pump so PSI should be no problem. I took the front cover off and the flames are just fine from low to high but no hot water. Going to drive me nuts til Monday unless somebody ran into the same problem. The eccotemp is brand new out of the box
Thanks
#1

6 Replies Related Threads

    lornaschinske
    Double Chili Cheeseburger
    • Total Posts : 1610
    • Joined: 2009/03/04 22:28:00
    • Location: Roswell, NM until we leave for another place
    • Status: offline
    Re:eccotemp L5 has no hot water 2011/09/30 23:00:55 (permalink)
    Try turning water flow down and gas flow up.
    #2
    Freezers-full-in-Alaska
    Cheeseburger
    • Total Posts : 132
    • Joined: 2010/10/14 20:30:00
    • Location: sunshine, AK
    • Status: offline
    Re:eccotemp L5 has no hot water 2011/10/01 00:16:14 (permalink)
    I screwed around with it for about 4 hours It will get hot after about 15sec.(110-120) but I have to have the sink on halfway if I turn the faucet all the way open it never gets hot or warm.
    #3
    edwmax
    Double Chili Cheeseburger
    • Total Posts : 2064
    • Joined: 2007/01/01 15:42:00
    • Location: Cairo, GA
    • Status: offline
    Re:eccotemp L5 has no hot water 2011/10/01 07:55:50 (permalink)
    Water is going thought the tank faster than it can be heated!   Turn the flow down.   Better yet, put an inline orifice in to restrict the flow.
    #4
    BackAlleyBurger
    Double Chili Cheeseburger
    • Total Posts : 1077
    • Joined: 2011/01/30 02:24:00
    • Location: FAYETTEVILLE, NC
    • Status: offline
    Re:eccotemp L5 has no hot water 2011/10/01 11:02:35 (permalink)
    yeppers, your ok it sounds....
    that pump is working faster then the heater can..... just turn up the flame, and turn down the flow a bit, like said use a flow restrictor, if you use it after the heater you should be able to leave the flames down a bit
    #5
    Freezers-full-in-Alaska
    Cheeseburger
    • Total Posts : 132
    • Joined: 2010/10/14 20:30:00
    • Location: sunshine, AK
    • Status: offline
    Re:eccotemp L5 has no hot water 2011/10/01 12:51:12 (permalink)
    Thanks everyone will give that a try
    #6
    Freezers-full-in-Alaska
    Cheeseburger
    • Total Posts : 132
    • Joined: 2010/10/14 20:30:00
    • Location: sunshine, AK
    • Status: offline
    Re:eccotemp L5 has no hot water 2011/10/01 14:05:49 (permalink)
    Thanks, That flow restrictor was the ticket
    #7
    Jump to:
    © 2014 APG vNext Commercial Version 5.1