fryer not lighting

Author Message
Dgaviolac
  • Total Posts : 64
  • Reward points : 0
  • Joined: 1/23/2013
  • Location: Hamptons, NY
fryer not lighting - Mon, 07/22/13 6:40 PM
0
propane guy just finished up the install and didnt test any of the appliances beause at the time the tank had not been filled. got the tank filled everything works except the fryer the pilot isnt a steady flame it sputters out than when I turn the gas on sometimes it doesnt light sometimes it takes a minute affter turning on the knob and it basically explodes out what coud be causing this? the tech doesnt have time to come til sunday and I have an even friday

Rcoy
  • Total Posts : 91
  • Reward points : 0
  • Joined: 3/13/2013
  • Location: Bremerton, WA
Re:fryer not lighting - Mon, 07/22/13 7:44 PM
0
If I had to guess, I would say the gas pressure is either high or low, have you tried adjusting the regulator?

BelCibo
  • Total Posts : 155
  • Reward points : 0
  • Joined: 11/20/2012
  • Location: Marsing, ID
Re:fryer not lighting - Tue, 07/23/13 8:14 AM
0
My Pitco does the same thing!  Lost some eyebrows over it too.
 
Here's how I've been working around it.  You have to get the pilot nice and hot.  I keep the lighter on the pilot for a long time, sometimes up to a minute.  It makes a sputtering sound like yours.  After it will run on it's own, I stick the flame in front of a burner and THEN turn on the temp control knob.  No more explosion.  After it warms up it's not an issue.
 
I took the pilot line off, cleaned out the jet but it made no difference.  Sounds like line pressure to me too.
 

Dgaviolac
  • Total Posts : 64
  • Reward points : 0
  • Joined: 1/23/2013
  • Location: Hamptons, NY
Re:fryer not lighting - Tue, 07/23/13 9:44 AM
0
after I remove th lighter it stays lit on its own but still sputters not a steady flame like it should be an id stick the lighter infront of the burner but id rather not get burnt a third time it was a brand new unit and just converte from ng to lp and im wondering if something was messed up there. the setup has a 100# tank with a dual stage regulator the burners and griddle came with theyre own regulators which the tech installed the fryer did not have one so it was installd without should I try adjusting the regulator or is there an adjustment on the fryer and how would I go about doing that

fishscale28
  • Total Posts : 224
  • Reward points : 0
  • Joined: 2/21/2013
  • Location: Fort Lauderdale, FL
Re:fryer not lighting - Tue, 07/23/13 11:54 AM
0
The fryer's regulator is built into the safety valve so you won't need an additional one (like your griddle).  Perhaps the safety valve isn't the right one (for propane)?  Did they change the valve and orifices on the fyer?  Have you tried just letting the pilot run for a while by itself before trying to fire up the fryer?  Maybe just running a decent amount of gas through it might help...
 

kozyman1
  • Total Posts : 4
  • Reward points : 0
  • Joined: 7/22/2013
  • Location: NW, OH
Re:fryer not lighting - Tue, 07/23/13 2:49 PM
0
Sounds like maybe it is a natural gas orafice? Not sure 

daddywoofdawg
  • Total Posts : 299
  • Reward points : 0
  • Joined: 2/23/2011
  • Location: Starkweather, ND
Re:fryer not lighting - Tue, 07/23/13 4:09 PM
0
the pilot light works by heating a spring or such if it's not hot enough it shuts closed.after lighting you must hold the button for at least 1 min.after the pilot stays lit let it run about five mins before starting the burner.is it blowing out?pressure to high, or is it running out pressure to low.one goes pop the other just fizzes out.

crazy
  • Total Posts : 7
  • Reward points : 0
  • Joined: 7/23/2013
  • Location: SFBA, CA
Re:fryer not lighting - Tue, 07/23/13 5:22 PM
0
If I might make a suggestion, look at your thermocouple. I had a brand new deep fryer for corndogs years ago. I was doing my first festival and it wouldn't stay lit. I called the rep that I bought it from and he blew me off. After some experimenting, i found out that was the problem.

Great forum by the way. I'm glad I found it.

jcheese
  • Total Posts : 740
  • Reward points : 0
  • Joined: 3/5/2011
  • Location: Fieldale, VA
Re:fryer not lighting - Tue, 07/23/13 6:38 PM
0
Check for spiders and their webs. If you have a thermocouple, make sure it impinges on the top 1/4 inch.

Dgaviolac
  • Total Posts : 64
  • Reward points : 0
  • Joined: 1/23/2013
  • Location: Hamptons, NY
Re:fryer not lighting - Tue, 07/23/13 7:27 PM
0
yes the valves and orifices were changed nt sure what a thermocouple is we checked manifold pressure today it was at just under 11 also I let it ur on just the pilot for atleast 5 minutes it lit not all the first time than after that no matter how long it wouldn't light

Uncle Groucho
  • Total Posts : 207
  • Reward points : 0
  • Joined: 11/2/2010
  • Location: Floyd County, IN
Re:fryer not lighting - Tue, 07/23/13 7:37 PM
0
What is the make and model of the fryer?
 

crazy
  • Total Posts : 7
  • Reward points : 0
  • Joined: 7/23/2013
  • Location: SFBA, CA
Re:fryer not lighting - Tue, 07/23/13 11:34 PM
0
The thermocouple is the doohickey that comes from the valve that turns from off to pilot to on. Yeah I know, highly technical terms but easy to figure out. It goes from the valve to the pilot light flame. It pokes into the flame. The flame heats the thermocouple up and sends a current, message, text or email back to the valve telling it to keep the gas on. If it is not working properly, your safety valve will shut the gas off. I'm not exactly sure if they are standard but any hardware store will have them. Check you manual to see if it has a replacement part number.

Dgaviolac
  • Total Posts : 64
  • Reward points : 0
  • Joined: 1/23/2013
  • Location: Hamptons, NY
Re:fryer not lighting - Wed, 07/24/13 7:50 AM
0
It's a 70# ad craft got it from a restaurant supply place is there an adjustment on this or however it's set is how it goes

crazy
  • Total Posts : 7
  • Reward points : 0
  • Joined: 7/23/2013
  • Location: SFBA, CA
Re:fryer not lighting - Wed, 07/24/13 1:53 PM
0
Are you asking me if there is an ajustment? If so, no. I think it's working or not. The part can't be more than $20 the last time I bought one.

Dgaviolac
  • Total Posts : 64
  • Reward points : 0
  • Joined: 1/23/2013
  • Location: Hamptons, NY
Re:fryer not lighting - Wed, 07/24/13 2:24 PM
0
well how do i determine if its bad without throwing parts at it also what would the gas spittering out like that mean istead of a steady flow

fishscale28
  • Total Posts : 224
  • Reward points : 0
  • Joined: 2/21/2013
  • Location: Fort Lauderdale, FL
Re:fryer not lighting - Wed, 07/24/13 4:41 PM
0
I thought I had problems with my coaxial thermopile (the version of a thermocouple on my fryer) and found this site :http://www.robertshawtsta...s-MillivoltSystems.pdf
 
If you have a comparable type thermopile/couple then the info here would help you figure out what you need to do to test it.
 
Have you called the people you bought it from, told them your issue and possibly inquired about having someone from there to check it out?  They might stand by their product and we willing to troubleshoot since you've not even used it nor had it working since you bought it...

Dgaviolac
  • Total Posts : 64
  • Reward points : 0
  • Joined: 1/23/2013
  • Location: Hamptons, NY
Re:fryer not lighting - Wed, 07/24/13 6:38 PM
0
well propane tech came over an swapped the orifice on the pilot light so the flame was much stonger and it works great im assuming that he forgot to do it when he onverted it but either way everything is great now and adjusted the regulator appropriatley

fishscale28
  • Total Posts : 224
  • Reward points : 0
  • Joined: 2/21/2013
  • Location: Fort Lauderdale, FL
Re:fryer not lighting - Wed, 07/24/13 6:51 PM
0
Good deal!