The most memorable local eateries along the highways and back roads of America
Sign In | Register for Free!
Restaurants Recipes Forums EatingTours Merchandise FAQ Maps Insider

 fryer not lighting

Author Message
Dgaviolac

  • Total Posts: 64
  • Joined: 1/23/2013
  • Location: Hamptons, NY
fryer not lighting Mon, 07/22/13 6:40 PM (permalink)
propane guy just finished up the install and didnt test any of the appliances beause at the time the tank had not been filled. got the tank filled everything works except the fryer the pilot isnt a steady flame it sputters out than when I turn the gas on sometimes it doesnt light sometimes it takes a minute affter turning on the knob and it basically explodes out what coud be causing this? the tech doesnt have time to come til sunday and I have an even friday
 
#1
    Rcoy

    • Total Posts: 91
    • Joined: 3/13/2013
    • Location: Bremerton, WA
    Re:fryer not lighting Mon, 07/22/13 7:44 PM (permalink)
    If I had to guess, I would say the gas pressure is either high or low, have you tried adjusting the regulator?
     
    #2
      BelCibo

      • Total Posts: 155
      • Joined: 11/20/2012
      • Location: Marsing, ID
      Re:fryer not lighting Tue, 07/23/13 8:14 AM (permalink)
      My Pitco does the same thing!  Lost some eyebrows over it too.
       
      Here's how I've been working around it.  You have to get the pilot nice and hot.  I keep the lighter on the pilot for a long time, sometimes up to a minute.  It makes a sputtering sound like yours.  After it will run on it's own, I stick the flame in front of a burner and THEN turn on the temp control knob.  No more explosion.  After it warms up it's not an issue.
       
      I took the pilot line off, cleaned out the jet but it made no difference.  Sounds like line pressure to me too.
       
       
      #3
        Dgaviolac

        • Total Posts: 64
        • Joined: 1/23/2013
        • Location: Hamptons, NY
        Re:fryer not lighting Tue, 07/23/13 9:44 AM (permalink)
        after I remove th lighter it stays lit on its own but still sputters not a steady flame like it should be an id stick the lighter infront of the burner but id rather not get burnt a third time it was a brand new unit and just converte from ng to lp and im wondering if something was messed up there. the setup has a 100# tank with a dual stage regulator the burners and griddle came with theyre own regulators which the tech installed the fryer did not have one so it was installd without should I try adjusting the regulator or is there an adjustment on the fryer and how would I go about doing that
         
        #4
          fishscale28

          • Total Posts: 223
          • Joined: 2/21/2013
          • Location: Fort Lauderdale, FL
          Re:fryer not lighting Tue, 07/23/13 11:54 AM (permalink)
          The fryer's regulator is built into the safety valve so you won't need an additional one (like your griddle).  Perhaps the safety valve isn't the right one (for propane)?  Did they change the valve and orifices on the fyer?  Have you tried just letting the pilot run for a while by itself before trying to fire up the fryer?  Maybe just running a decent amount of gas through it might help...
           
           
          #5
            kozyman1

            • Total Posts: 4
            • Joined: 7/22/2013
            • Location: NW, OH
            Re:fryer not lighting Tue, 07/23/13 2:49 PM (permalink)
            Sounds like maybe it is a natural gas orafice? Not sure 
             
            #6
              daddywoofdawg

              • Total Posts: 299
              • Joined: 2/23/2011
              • Location: Starkweather, ND
              Re:fryer not lighting Tue, 07/23/13 4:09 PM (permalink)
              the pilot light works by heating a spring or such if it's not hot enough it shuts closed.after lighting you must hold the button for at least 1 min.after the pilot stays lit let it run about five mins before starting the burner.is it blowing out?pressure to high, or is it running out pressure to low.one goes pop the other just fizzes out.
               
              #7
                crazy

                • Total Posts: 7
                • Joined: 7/23/2013
                • Location: SFBA, CA
                Re:fryer not lighting Tue, 07/23/13 5:22 PM (permalink)
                If I might make a suggestion, look at your thermocouple. I had a brand new deep fryer for corndogs years ago. I was doing my first festival and it wouldn't stay lit. I called the rep that I bought it from and he blew me off. After some experimenting, i found out that was the problem.

                Great forum by the way. I'm glad I found it.
                 
                #8
                  jcheese

                  • Total Posts: 739
                  • Joined: 3/5/2011
                  • Location: Fieldale, VA
                  Re:fryer not lighting Tue, 07/23/13 6:38 PM (permalink)
                  Check for spiders and their webs. If you have a thermocouple, make sure it impinges on the top 1/4 inch.
                   
                  #9
                    Dgaviolac

                    • Total Posts: 64
                    • Joined: 1/23/2013
                    • Location: Hamptons, NY
                    Re:fryer not lighting Tue, 07/23/13 7:27 PM (permalink)
                    yes the valves and orifices were changed nt sure what a thermocouple is we checked manifold pressure today it was at just under 11 also I let it ur on just the pilot for atleast 5 minutes it lit not all the first time than after that no matter how long it wouldn't light
                     
                    #10
                      Uncle Groucho

                      • Total Posts: 207
                      • Joined: 11/2/2010
                      • Location: Floyd County, IN
                      Re:fryer not lighting Tue, 07/23/13 7:37 PM (permalink)
                      What is the make and model of the fryer?
                       
                       
                      #11
                        crazy

                        • Total Posts: 7
                        • Joined: 7/23/2013
                        • Location: SFBA, CA
                        Re:fryer not lighting Tue, 07/23/13 11:34 PM (permalink)
                        The thermocouple is the doohickey that comes from the valve that turns from off to pilot to on. Yeah I know, highly technical terms but easy to figure out. It goes from the valve to the pilot light flame. It pokes into the flame. The flame heats the thermocouple up and sends a current, message, text or email back to the valve telling it to keep the gas on. If it is not working properly, your safety valve will shut the gas off. I'm not exactly sure if they are standard but any hardware store will have them. Check you manual to see if it has a replacement part number.
                         
                        #12
                          Dgaviolac

                          • Total Posts: 64
                          • Joined: 1/23/2013
                          • Location: Hamptons, NY
                          Re:fryer not lighting Wed, 07/24/13 7:50 AM (permalink)
                          It's a 70# ad craft got it from a restaurant supply place is there an adjustment on this or however it's set is how it goes
                           
                          #13
                            crazy

                            • Total Posts: 7
                            • Joined: 7/23/2013
                            • Location: SFBA, CA
                            Re:fryer not lighting Wed, 07/24/13 1:53 PM (permalink)
                            Are you asking me if there is an ajustment? If so, no. I think it's working or not. The part can't be more than $20 the last time I bought one.
                             
                            #14
                              Dgaviolac

                              • Total Posts: 64
                              • Joined: 1/23/2013
                              • Location: Hamptons, NY
                              Re:fryer not lighting Wed, 07/24/13 2:24 PM (permalink)
                              well how do i determine if its bad without throwing parts at it also what would the gas spittering out like that mean istead of a steady flow
                               
                              #15
                                fishscale28

                                • Total Posts: 223
                                • Joined: 2/21/2013
                                • Location: Fort Lauderdale, FL
                                Re:fryer not lighting Wed, 07/24/13 4:41 PM (permalink)
                                I thought I had problems with my coaxial thermopile (the version of a thermocouple on my fryer) and found this site :http://www.robertshawtsta...s-MillivoltSystems.pdf
                                 
                                If you have a comparable type thermopile/couple then the info here would help you figure out what you need to do to test it.
                                 
                                Have you called the people you bought it from, told them your issue and possibly inquired about having someone from there to check it out?  They might stand by their product and we willing to troubleshoot since you've not even used it nor had it working since you bought it...
                                 
                                #16
                                  Dgaviolac

                                  • Total Posts: 64
                                  • Joined: 1/23/2013
                                  • Location: Hamptons, NY
                                  Re:fryer not lighting Wed, 07/24/13 6:38 PM (permalink)
                                  well propane tech came over an swapped the orifice on the pilot light so the flame was much stonger and it works great im assuming that he forgot to do it when he onverted it but either way everything is great now and adjusted the regulator appropriatley
                                   
                                  #17
                                    fishscale28

                                    • Total Posts: 223
                                    • Joined: 2/21/2013
                                    • Location: Fort Lauderdale, FL
                                    Re:fryer not lighting Wed, 07/24/13 6:51 PM (permalink)
                                    Good deal!
                                     
                                     
                                    #18
                                      Online Bookmarks Sharing: Share/Bookmark

                                      Jump to:

                                      Current active users

                                      There are 0 members and 1 guests.

                                      Icon Legend and Permission

                                      • New Messages
                                      • No New Messages
                                      • Hot Topic w/ New Messages
                                      • Hot Topic w/o New Messages
                                      • Locked w/ New Messages
                                      • Locked w/o New Messages
                                      • Read Message
                                      • Post New Thread
                                      • Reply to message
                                      • Post New Poll
                                      • Submit Vote
                                      • Post reward post
                                      • Delete my own posts
                                      • Delete my own threads
                                      • Rate post

                                      2000-2014 ASPPlayground.NET Forum Version 3.9
                                      What is Roadfood?  |   Privacy Policy  |   Contact Roadfood.com   Copyright 2011 - Roadfood.com