The most memorable local eateries along the highways and back roads of America
Sign In | Register for Free!
Restaurants Recipes Forums EatingTours Merchandise FAQ Maps Insider

 eccotemp L5 has no hot water

Author Message
Freezers-full-in-Alaska

  • Total Posts: 132
  • Joined: 10/14/2010
  • Location: sunshine, AK
eccotemp L5 has no hot water Fri, 09/30/11 9:40 PM (permalink)
Subject title says it all,No hot water from my L5 eccotemp . Of course it is Friday and trouble shooting line is closed. Anybody have any ideas? I have a 45psi sur-flo pump so PSI should be no problem. I took the front cover off and the flames are just fine from low to high but no hot water. Going to drive me nuts til Monday unless somebody ran into the same problem. The eccotemp is brand new out of the box
Thanks
 
#1
    lornaschinske

    • Total Posts: 1610
    • Joined: 3/4/2009
    • Location: Roswell, NM until we leave for another place
    Re:eccotemp L5 has no hot water Fri, 09/30/11 11:00 PM (permalink)
    Try turning water flow down and gas flow up.
     
    #2
      Freezers-full-in-Alaska

      • Total Posts: 132
      • Joined: 10/14/2010
      • Location: sunshine, AK
      Re:eccotemp L5 has no hot water Sat, 10/1/11 12:16 AM (permalink)
      I screwed around with it for about 4 hours It will get hot after about 15sec.(110-120) but I have to have the sink on halfway if I turn the faucet all the way open it never gets hot or warm.
       
      #3
        edwmax

        • Total Posts: 2015
        • Joined: 1/1/2007
        • Location: Cairo, GA
        Re:eccotemp L5 has no hot water Sat, 10/1/11 7:55 AM (permalink)
        Water is going thought the tank faster than it can be heated!   Turn the flow down.   Better yet, put an inline orifice in to restrict the flow.
         
        #4
          BackAlleyBurger

          • Total Posts: 1077
          • Joined: 1/30/2011
          • Location: FAYETTEVILLE, NC
          Re:eccotemp L5 has no hot water Sat, 10/1/11 11:02 AM (permalink)
          yeppers, your ok it sounds....
          that pump is working faster then the heater can..... just turn up the flame, and turn down the flow a bit, like said use a flow restrictor, if you use it after the heater you should be able to leave the flames down a bit
           
          #5
            Freezers-full-in-Alaska

            • Total Posts: 132
            • Joined: 10/14/2010
            • Location: sunshine, AK
            Re:eccotemp L5 has no hot water Sat, 10/1/11 12:51 PM (permalink)
            Thanks everyone will give that a try
             
            #6
              Freezers-full-in-Alaska

              • Total Posts: 132
              • Joined: 10/14/2010
              • Location: sunshine, AK
              Re:eccotemp L5 has no hot water Sat, 10/1/11 2:05 PM (permalink)
              Thanks, That flow restrictor was the ticket
               
              #7
                Online Bookmarks Sharing: Share/Bookmark

                Jump to:

                Current active users

                There are 0 members and 2 guests.

                Icon Legend and Permission

                • New Messages
                • No New Messages
                • Hot Topic w/ New Messages
                • Hot Topic w/o New Messages
                • Locked w/ New Messages
                • Locked w/o New Messages
                • Read Message
                • Post New Thread
                • Reply to message
                • Post New Poll
                • Submit Vote
                • Post reward post
                • Delete my own posts
                • Delete my own threads
                • Rate post

                2000-2014 ASPPlayground.NET Forum Version 3.9
                What is Roadfood?  |   Privacy Policy  |   Contact Roadfood.com   Copyright 2011 - Roadfood.com